Products

LockDown Browser Requirements

LockDown Browser

System Requirements

LockDown Browser System Requirements

Operating Systems
Windows: 10, 8, 7
Mac: OS X 10.10 or higher
iOS: 7.0+ (iPad only). Must have a compatible LMS integration. Details.
Chromebook: (K-12 only). Details.

Memory

Windows: 2 GB RAM
Mac: 512 MB RAM

Browser Requirements

LockDown Browser is a client application that is installed to a local computer. Both the Windows edition and the Mac edition of the browser are based on Chromium, Google's open source framework. Students do NOT need Google's Chrome browser installed; nor will this version affect a Chrome browser that's already installed.

Learning Management Systems

LockDown Browser integrates with the following learning management systems:

  • Blackboard Learn 9.1 or higher
  • Brightspace 10.x
  • Canvas
  • Moodle 2.x to 3.x
  • Schoology Enterprise
  • Sakai 2.7.1+